use strict;
my $str = '{"location":[22.99902,66.000],"t":1},
{"location":[55.32168,140.556],"t":2},
{"location":[85.0002,20.0055],"t":3},
{"location": [4, 4], "smth": val, "t":2},
{"t": 2, "location": [value2], "something else": some_value}';
my $regex = qr/(?<=\{)(?=.*?\"t\"\s*:\s*2).*?(?=\})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}