const regex = /(?<=\{)(?=.*?\"t\"\s*:\s*2).*?(?=\})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\{)(?=.*?\\"t\\"\\s*:\\s*2).*?(?=\\})', 'gm')
const str = `{"location":[22.99902,66.000],"t":1},
{"location":[55.32168,140.556],"t":2},
{"location":[85.0002,20.0055],"t":3},
{"location": [4, 4], "smth": val, "t":2},
{"t": 2, "location": [value2], "something else": some_value}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}