# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/_ABC(?:(?!_ABC).)+$/_CBA/gm;t' <<< "_AB:C-_ABCDEF_ABC:45_ABC:454:
_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:"