$re = '/_ABC(?:(?!_ABC).)+$/m';
$str = '_AB:C-_ABCDEF_ABC:45_ABC:454:
_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:';
$subst = "_CBA";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;