use strict;
my $str = '_AB:C-_ABCDEF_ABC:45_ABC:454:
_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:';
my $regex = qr/_ABC(?:(?!_ABC).)+$/mp;
my $subst = '_CBA';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";