import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_ABC(?:(?!_ABC).)+$";
final String string = "_AB:C-_ABCDEF_ABC:45_ABC:454:\n"
+ "_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:";
final String subst = "_CBA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}