re = /_ABC(?:(?!_ABC).)+$/m
str = '_AB:C-_ABCDEF_ABC:45_ABC:454:
_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:'
subst = '_CBA'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result