#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)_ABC(?:(?!_ABC).)+$"
Local $sString = "_AB:C-_ABCDEF_ABC:45_ABC:454:" & @CRLF & _
"_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:"
Local $sSubst = "_CBA"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)