using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_ABC(?:(?!_ABC).)+$";
string substitution = @"_CBA";
string input = @"_AB:C-_ABCDEF_ABC:45_ABC:454:
_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}