const regex = /_ABC(?:(?!_ABC).)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_ABC(?:(?!_ABC).)+$', 'gm')
const str = `_AB:C-_ABCDEF_ABC:45_ABC:454:
_AB:C-_ABCDEF_ABC:45_ABC_ABC:454:`;
const subst = `_CBA`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);