#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$"
Local $sString = "# JIRA Board Names" & @CRLF & _
"TODO (SI-6):" & @CRLF & _
"TODO (SIT-66):" & @CRLF & _
"TODO (SITT-666):" & @CRLF & _
"TODO (SITTT-6666):" & @CRLF & _
"" & @CRLF & _
"# Different Dash Formats" & @CRLF & _
"TODO (SITT—6666):" & @CRLF & _
"TODO (SITT–6666):" & @CRLF & _
"TODO (SITT-6666):" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")