use strict;
my $str = '# JIRA Board Names
TODO (SI-6):
TODO (SIT-66):
TODO (SITT-666):
TODO (SITTT-6666):
# Different Dash Formats
TODO (SITT—6666):
TODO (SITT–6666):
TODO (SITT-6666):
';
my $regex = qr/^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}