using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$";
string input = @"# JIRA Board Names
TODO (SI-6):
TODO (SIT-66):
TODO (SITT-666):
TODO (SITTT-6666):
# Different Dash Formats
TODO (SITT—6666):
TODO (SITT–6666):
TODO (SITT-6666):
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}