import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^TODO \\(\\w{2,6}[-|–|—]\\d{1,6}\\):.*$";
final String string = "# JIRA Board Names\n"
+ "TODO (SI-6):\n"
+ "TODO (SIT-66):\n"
+ "TODO (SITT-666):\n"
+ "TODO (SITTT-6666):\n\n"
+ "# Different Dash Formats\n"
+ "TODO (SITT—6666):\n"
+ "TODO (SITT–6666):\n"
+ "TODO (SITT-6666):\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}