import re
regex = re.compile(r"^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$", flags=re.MULTILINE)
test_str = ("# JIRA Board Names\n"
"TODO (SI-6):\n"
"TODO (SIT-66):\n"
"TODO (SITT-666):\n"
"TODO (SITTT-6666):\n\n"
"# Different Dash Formats\n"
"TODO (SITT—6666):\n"
"TODO (SITT–6666):\n"
"TODO (SITT-6666):\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")