const regex = /^TODO \(\w{2,6}[-|–|—]\d{1,6}\):.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^TODO \\(\\w{2,6}[-|–|—]\\d{1,6}\\):.*$', 'gm')
const str = `# JIRA Board Names
TODO (SI-6):
TODO (SIT-66):
TODO (SITT-666):
TODO (SITTT-6666):
# Different Dash Formats
TODO (SITT—6666):
TODO (SITT–6666):
TODO (SITT-6666):
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}