# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<="token":")[^"]+(?=")/78919/gm;t' <<< "{\"name\": \"Zahid\",\"token\":\"123456\"}"