import re
regex = re.compile(r"(?<=\"token\":\")[^\"]+(?=\")", flags=re.MULTILINE)
test_str = "{\"name\": \"Zahid\",\"token\":\"123456\"}"
subst = "78919"
result = regex.sub(subst, test_str)
if result:
print(result)