$re = '/(?<="token":")[^"]+(?=")/m';
$str = '{"name": "Zahid","token":"123456"}';
$subst = "78919";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;