using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""token"":"")[^""]+(?="")";
string substitution = @"78919";
string input = @"{""name"": ""Zahid"",""token"":""123456""}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}