re = /(?<="token":")[^"]+(?=")/m
str = '{"name": "Zahid","token":"123456"}'
subst = '78919'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result