#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<="token":")[^"]+(?=")"
Local $sString = "{"name": "Zahid","token":"123456"}"
Local $sSubst = "78919"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)