# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"[^"]+"(*SKIP)(*FAIL)
|
\(
(?:[^()]*|(?R))+
\)//gmx;t' <<< "\"Hello World (Don't want to strip this (also not this))\" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))
"