$re = '~"[^"]+"(*SKIP)(*FAIL)
|
\(
(?:[^()]*|(?R))+
\)~mx';
$str = '"Hello World (Don\'t want to strip this (also not this))" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;