import re
regex = re.compile(r"""
"[^"]+"(*SKIP)(*FAIL)
|
\(
(?:[^()]*|(?R))+
\)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("\"Hello World (Don't want to strip this (also not this))\" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)