re = /"[^"]+"(*SKIP)(*FAIL)
|
\(
(?:[^()]*|(?R))+
\)/mx
str = '"Hello World (Don\'t want to strip this (also not this))" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result