import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]+\"(*SKIP)(*FAIL)\n"
+ "|\n"
+ "\\(\n"
+ " (?:[^()]*|(?R))+\n"
+ "\\)";
final String string = "\"Hello World (Don't want to strip this (also not this))\" anything outside round brackets should remain as is(strip this (strip this also as it is outside double quotes))\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}