# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])//gm;t' <<< "aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn"