re = /(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])/m
str = 'aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result