const regex = /(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|\\[[^][|]*\\|)[^][\\s]*\\K\\s+(?=[^][]*])', 'gm')
const str = `aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);