using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])";
string substitution = @"";
string input = @"aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}