import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|\\[[^][|]*\\|)[^][\\s]*\\K\\s+(?=[^][]*])";
final String string = "aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}