import Foundation
let pattern = #"(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)