use strict;
my $str = 'aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn';
my $regex = qr/(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";