$re = '/(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])/m';
$str = 'aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;