#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!\A)|\[[^][|]*\|)[^][\s]*\K\s+(?=[^][]*])"
Local $sString = "aaa [My Test URL|https://ww w.mywebsite.c om/t est?param=123] nnn"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)