#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\"\$basetexture\".*)"
Local $sString = ""LightmappedGeneric"" & @CRLF & _
"{" & @CRLF & _
" "$basetexture" "Concrete/concrete_modular_floor001a"" & @CRLF & _
" "$surfaceprop" "concrete"" & @CRLF & _
" "%keywords" "portal"" & @CRLF & _
"}" & @CRLF & _
""LightmappedGeneric"" & @CRLF & _
"{" & @CRLF & _
" "$nobasetexture" "Concrete/concrete_modular_floor001a"" & @CRLF & _
" "$surfaceprop" "concrete"" & @CRLF & _
" "%keywords" "portal"" & @CRLF & _
"}"
Local $sSubst = "\1\n\t"$basetexturetransform" "center .5 .5 scale 4 4 rotate 0 translate 0 0""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)