using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""\$basetexture\"".*)";
string substitution = @"\1\n\t""$basetexturetransform"" ""center .5 .5 scale 4 4 rotate 0 translate 0 0""";
string input = @"""LightmappedGeneric""
{
""$basetexture"" ""Concrete/concrete_modular_floor001a""
""$surfaceprop"" ""concrete""
""%keywords"" ""portal""
}
""LightmappedGeneric""
{
""$nobasetexture"" ""Concrete/concrete_modular_floor001a""
""$surfaceprop"" ""concrete""
""%keywords"" ""portal""
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}