package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\"\$basetexture\".*)`)
var str = `"LightmappedGeneric"
{
"$basetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}
"LightmappedGeneric"
{
"$nobasetexture" "Concrete/concrete_modular_floor001a"
"$surfaceprop" "concrete"
"%keywords" "portal"
}`
var substitution = "\1\n\t"$basetexturetransform" "center .5 .5 scale 4 4 rotate 0 translate 0 0""
fmt.Println(re.ReplaceAllString(str, substitution))
}