const regex = new RegExp('(\\"\\$basetexture\\".*)', 'gm')
const str = `"LightmappedGeneric"
{
"\$basetexture" "Concrete/concrete_modular_floor001a"
"\$surfaceprop" "concrete"
"%keywords" "portal"
}
"LightmappedGeneric"
{
"\$nobasetexture" "Concrete/concrete_modular_floor001a"
"\$surfaceprop" "concrete"
"%keywords" "portal"
}`;
const subst = `\1\n\t"$basetexturetransform" "center .5 .5 scale 4 4 rotate 0 translate 0 0"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);