#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)"
Local $sString = " --> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`" & @CRLF & _
" |" & @CRLF & _
"55 | 4u8 => unimplemented!(); 42," & @CRLF & _
" | -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here" & @CRLF & _
" | |" & @CRLF & _
" | while parsing the `match` arm starting here" & @CRLF & _
"" & @CRLF & _
" --> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size" & @CRLF & _
" |" & @CRLF & _
" | errors are bad, mkay?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")