use strict;
my $str = ' --> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`
|
55 | 4u8 => unimplemented!(); 42,
| -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here
| |
| while parsing the `match` arm starting here
--> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size
|
| errors are bad, mkay?
';
my $regex = qr/ +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}