import Foundation
let pattern = #" +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
--> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`
|
55 | 4u8 => unimplemented!(); 42,
| -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here
| |
| while parsing the `match` arm starting here
--> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size
|
| errors are bad, mkay?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)