# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)"
test_str = (" --> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`\n"
" |\n"
"55 | 4u8 => unimplemented!(); 42,\n"
" | -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here\n"
" | |\n"
" | while parsing the `match` arm starting here\n\n"
" --> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size\n"
" |\n"
" | errors are bad, mkay?\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.