const regex = / +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' +--> +([a-zA-Z_\\\/.-]+):(\\d+):(\\d+)::::(.*)', 'gm')
const str = ` --> src/blah.rs:55:32::::error: expected one of \`,\`, \`.\`, \`?\`, \`}\`, or an operator, found \`;\`
|
55 | 4u8 => unimplemented!(); 42,
| -- ^ expected one of \`,\`, \`.\`, \`?\`, \`}\`, or an operator here
| |
| while parsing the \`match\` arm starting here
--> src/foobar.rs:4:1::::error[E0072]: recursive type \`foo::Bar\` has infinite size
|
| errors are bad, mkay?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}