// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)").unwrap();
let string = " --> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`
|
55 | 4u8 => unimplemented!(); 42,
| -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here
| |
| while parsing the `match` arm starting here
--> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size
|
| errors are bad, mkay?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}