import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " +--> +([a-zA-Z_\\/.-]+):(\\d+):(\\d+)::::(.*)";
final String string = " --> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`\n"
+ " |\n"
+ "55 | 4u8 => unimplemented!(); 42,\n"
+ " | -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here\n"
+ " | |\n"
+ " | while parsing the `match` arm starting here\n\n"
+ " --> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size\n"
+ " |\n"
+ " | errors are bad, mkay?\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}