using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" +--> +([a-zA-Z_\/.-]+):(\d+):(\d+)::::(.*)";
string input = @" --> src/blah.rs:55:32::::error: expected one of `,`, `.`, `?`, `}`, or an operator, found `;`
|
55 | 4u8 => unimplemented!(); 42,
| -- ^ expected one of `,`, `.`, `?`, `}`, or an operator here
| |
| while parsing the `match` arm starting here
--> src/foobar.rs:4:1::::error[E0072]: recursive type `foo::Bar` has infinite size
|
| errors are bad, mkay?
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}