# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)/\1;\4/gm;t' <<< "1,,,4"