$re = '/^(?:(\d+)|),(?:(\d+)|),(?:(\d+)|),(?:(\d+)|)/m';
$str = '1,,,4';
$subst = "\1;\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;